VisualVision: professional content publishing software - Web site, self installing CD DVD, catalog, protect ebook, autoplay CD brochure, HTML Help, manual, guide, reference, database import CSV

Welcome, Guest. Please Login or Register.
Dec 18th, 2017, 1:29pm

(this forum was - and actually still is - here)

Home Home Help Help Search Search Members Members Login Login Register Register
Visual Vision **User's** Forum (the fast) « Post reply »



Français (Google)
software free download
Español (Google)
software free download
Italiano
 
create Website1SITE: create a business or personal Website with ease...
software support
manuals, documentation on CDCDFrontEnd: distribute documentation, CD brochures & CD business cards; protect CD (Fra, Ita)
software free download
create Web CD catalogHyperPublish: create Website, product catalog (also from DB CSV), multimedia CD... (Ita)
software free download
create ebookEBooksWriter: edit, pack and protect smart ebooks... (Esp, Ita)
cd software
create manualPaperKiller: create a manual, hypertext, manage electronic documentation
software free download
software documentationRoboAuthor: make software helpfile and documentation .CHM .HLP HTML Help
software free download
host hostingVisionHost: web space hosting for VV customers
software free download
create a Web siteEasyWebEditor: build your own Web site, create good Internet pages without code or "HTML"
software free download
Français (Google)
Créer une page Internet personnelle ou d'entreprise avec facilité; distribuer de la documentation, des brochures avec CD DVD à démarrage automatique / auto exécutable, protéger CD / DVD; logiciel pour catalogue de produits (database, CSV); modifier, emballer et protéger ebooks; créer un manuel, un hypertexte, gérer la documentation électronique; construire votre site Web, créer des pages...
software free download
Español (Google)
Crear un negocio o sitio web personal con facilidad; distribuir la documentación, manuales, folletos y CD / DVD tarjetas de visita; proteger CD; crear catálogo de productos (database, CSV), editar, empaquetar y proteger ebook; crear un manual, hipertexto, gestión de documentación electrónica y ayuda CHM y HLP; construir su propio sitio Web, crear páginas de Internet...
software free download
Search:  
Advanced search...

Max results:

   Visual Vision **User's** Forum (the fast)
   Our Products
   EasyWebEditor / 1site
   Post reply ( Re: workaround for IE7 bug with frames )
Post reply

NOTICE: Maybe your question has been already answered: search for existing replies by using the easy Search feature on the top!
Subject:
Full name:
Email:
Message icon:
Add YABBC tags:
Add Smileys:
Message:

Disable Smilies:

Check this if you'll be adding code (or don't like smileys).

To confirm that you are human write OK, uppercase::
(by the way we have several filters in place and we monitor everything, so don't loose time)
shortcuts (IE and NS6 only): hit alt+s to send, alt+p to preview, or alt+r to reset


Topic Summary
Posted by: Support Staff Posted on: Nov 30th, 2006, 4:15pm
As you may know, IE7 has (at the time we write) a serious bug with frames and the BASE tag.
Basically, while since HTML2.0 it is perfectly legal to use this particular code both within HEAD and/or within BODY, IE7 ignores it if within the BODY.
 
A workaround is to add, for each page, with "Insert >HTML >At page start" this code:
 
<BASE target="_top">
 
 
 
Posted by: Tina Emmott Posted on: Dec 1st, 2006, 11:44am
I have read it three times - and had a go, but where do I find "page starts" within "insert" in order to paste: <BASE target="_top">  
 
 
 
Tina
Posted by: Support Staff Posted on: Dec 1st, 2006, 11:50am
Open EasyWebEditor or 1SITE.
 
From the main menu, choose
"Insert"
from the list, click on
"HTML"
then choose
"At page start".
 
These indications are not valid if you are using a different software for your Web site....
Posted by: ann val Posted on: Dec 9th, 2006, 1:51pm
If I use this code to make the site compatible with ie7. will the site still be compatible with the other browsers?
Posted by: Support Staff Posted on: Dec 9th, 2006, 2:12pm
Yes, this is just a duplication of a code that already is on the page. IE7 needs it replicated.
The other browsers will just ignore the duplication.
Posted by: Bryan Posted on: Dec 14th, 2006, 7:35am
Thank you for this info! So this "fix" should be inserted after the initial metatag data and after the <head> - correct?
Posted by: Support Staff Posted on: Dec 14th, 2006, 7:44am
yes the <base....> must be inserted in the "Format >Page properties >Script/Meta"
if you have some meta tag, you can insert the <base > after them. Or before. It's the same.
 
please notice that <head> is inserted by the program automatically, you must not insert <head> or it will be a duplicate
Posted by: Bryan Posted on: Dec 14th, 2006, 5:30pm
Great! Thank you for the info. I keep telling people to go back to Explorer 6.0, as 7.0 seems to be a monster and reeking havoc with 9 out of 10 people. Thanks again fo rthis fix. It saves from having to redo an entire website.
Posted by: Paul Snizek Posted on: Dec 28th, 2006, 4:57am
I inserted the tag in the Index page. My son, who has IE7 says it still does not work properly. Do I need to insert the tag on every htm page?
Posted by: Support Staff Posted on: Dec 28th, 2006, 6:33am
Yes, all pages. Boring, I know!
Posted by: Paul Snizek Posted on: Dec 29th, 2006, 12:23am
IT'S WORKING! IT'S WORKING!
I love you Site1  
Happy 2007.
Posted by: Sue Parracino Posted on: Jan 28th, 2007, 4:24pm
Hello,
 
I have seen the workaround solution for the IE bug; and have applied it to all pages, however it doesn't seem to work!?
 
I have done what it says, such as:
 
From main menu, I chose "Insert > HTML > At Page Start"  Then I pasted  "<BASE TARGET=_TOP">  in the large box, and clicked OK.  
 
Am I missing something??  Please Advise!!
 
Sue
Posted by: Paul Snizek Posted on: Jan 29th, 2007, 2:36am
Hey there - I did it and it works!
You got the formula backwards
<BASE target="_top">  
 
and on every page, too! I have some 200 of them!
 
Go for it
Paul
Posted by: Support Staff Posted on: Jan 29th, 2007, 6:13am
It is
 <BASE target="_top">  
not
"<BASE target=_top">  
 
On all pages (you may use CTRL + and CTRL - to span pages).
 
Also, you must republish all the website after the change (to force a complete republish, press the All button on the bottom left before pressing the big Publish button)
 
Last but not least you may have to delete the browser's "cache" (internal memory), i.e. force the browser to reload the new pages  (SHIFT + Reload button is normally sufficient; Reload button: between the address bar and the red X stop button)
Posted by: Sue Parracino Posted on: Jan 29th, 2007, 7:59am
Hi,
 
I appreciate all your help!!
 
Actually, I did have the formula correct, as I pasted it in - I just mis-typed it in my question.
 
I also did click on the "all" button prior to publishing, so it must be the browsers "cache" that needs to be deleted.  
 
I have never done this, and I'm having some difficulty, what page do I find the reload button on?  
 
Sue
 
 
Posted by: Support Staff Posted on: Jan 29th, 2007, 8:56am
in Internet Explorer 7 the page reload button is besides the address bar, on the right
 
the address bar is on the top of IE7 and shows the address of your web site.
Posted by: Sue Parracino Posted on: Jan 29th, 2007, 10:18am
Hi,
 
OK, I started from scratch.  I found the reload button, aka "refresh" button??  I held down the shift button and clicked the refresh button.
 
Then I went back to the website and rechecked every page for <Base target="_top">
Is there suppose to be a space between Base and target??
 
Then I hit the "All" button and then I Published.
 
NO LUCK!!!!  What on earth am I doing wrong??  PLEASE HELP!!!
 
Sue
Posted by: Sue Parracino Posted on: Jan 29th, 2007, 10:22am
Hi Again,
 
Was I suppose to click on "Load" or "Save" after entering the <Base... prior to clicking OK?
 
I only pasted the <Base... and hit OK.
 
I have no clue what's wrong!!!
 
Sue
Posted by: Support Staff Posted on: Jan 29th, 2007, 12:07pm
the only thing to do is to add this tag for each page / frame with Insert >HTML >At page start
 
what is the web site?
write it as (or your post will be forbidden)
 
www. thewebsite .com
 
and we will take a look. By reading the code it will be easy to find your mistake.......
Posted by: Sue Parracino Posted on: Jan 29th, 2007, 12:14pm
Hi,
 
Thanks for all your efforts!!  The web address is:  
www.ParracinosLabs.com  
 
I don't see any HTML code to add the "BASE formula to.  I just pasted it into the box and hit OK.  Then I hit All & Publish.
 
Let me know, Thanks!
 
Sue
Posted by: Support Staff Posted on: Jan 29th, 2007, 12:55pm
Hi! There is normally no HTML code in
Insert >HTML >At start
 
This is a place where YOU can add the HTML code.
For correcting the IE7 bug you must add there:
 
<base target="_top">
 
 
I see you added this code probably only to your very first page.
As said three or four times in this topic, you must add this code to EACH page of your web site.
 
Use CTRL + and CTRL - to span all pages.
 
This means you must do the operation described above for page 0, page 1, page 2, page 3, etc etc etc etc (some of your pages are the frames you see).
 
Please do this then republish all the website and it will work.
 
To say one, in your page 1 you didn't add the tag (with Insert >HTML >At start ). It must be added in ALL pages / frames. It is a boring task but it works . Be patient and precise!
Posted by: Sue Parracino Posted on: Jan 29th, 2007, 3:03pm
Hi,
 
I know that this must be very frustrating for you, however, it's ten time as frustrating for me.  I DID add it to EVERY page of my web site.  Unless I misunderstand the meaning of a page, I am doing it right.
 
I have added that code to every page listed on my index that is found to the left of the front page.  In addition, I added it to every page that has a link, making sure that I have not forgotten one!
 
I'm not sure how the ctl + ctl works, I just did what you have mentioned.
 
On every page, from the main menu, I went to "Insert" then I clicked on "HTML" then I chose "At page start".  Now I inserted the code in the large box provided for HTML; as you said, and I then clicked on OK.  Then I proceded to do the same to every page on my menu in addition to all pages that  were linked from another!!
 
I am trying my very best!  My individual pages consist of tables, not frames, and I know that I  entered it on all pages!  
 
Was the browers cache deleted correctly?
 
I will try it again...Is there any other suggestion that you may have?
 
Sue
 
Posted by: Support Staff Posted on: Jan 29th, 2007, 3:14pm
Hi, as anybody can see by reading the code in the left frame of your website, this code does not contain the <base.... addition.
 
Please go to page 1 and add that code.
 
Step by step:
 
- open your EWE file
 
- on the bottom center box (page number box), type 1
(the number 1, one), then press the carriage return key on the keyboard (labeled as Enter or Return)
 
- now the bottom center box (page number box) must show the number 1. As far as I can see from the web, the name of that page is "Link Menu"
 
- to be sure, release the frame/noframe toolbar button. This button is on the right of the page number box, and it is normally pressed. Release it (click on it)
 
- on the main menu, click Insert. Then from the drop down menu that will be shown, click HTML, then click "At page start"
 
- a dialog will be shown. On the big gray editable part of the dialog (bottom left) type this
 
<base target="_top">
 
then press the OK button
 
- type something at the bottom of the left frame, such as "I am testing" or simply "****" : this will help you to check on the web that this %&&&$$ left frame will be actually updated on the web (who knows, maybe you did the modification but for some reasons you are not actually publishing it)
 
- save your edit file (from the main menu, File, then Save all)
 
- publish your website as per the Internet Publishing Tutorial
 
http://www.easy-web-editor.net/website_builder/website_builder_software- 000009.htm
 
but, to be definitely sure, before the big Publish button, press the All button that is on the bottom left of the publishing dialog
 
 
 
P.S: CTRL + means:
 
- hold down the CTRL key on the keyboard (there are 2 keys with the label CTRL on the keyboard, just hold down one, no matter what), then hit the + key (the one on the main keyboard - not numeric keypad) with your finger. This action increases the page number (you go to the next page in numeric order).
 
CTRL - goes to the previous page.
Posted by: Sue Parracino Posted on: Jan 29th, 2007, 4:27pm
THANK YOU, THANK YOU, THANK YOU!!!!!!!!!!!
 
Thank You for all of your patience!!!!!!!!!!!
 
I did miss a few pages because I was going by the index on my web site.  I didn't realize that there was a page counter at the bottom!  
 
One more question...If I add a page to the web site, do I also add that code??
 
Thank you sooooooo much!!!!!!!!!!!
 
Sue      
Posted by: Support Staff Posted on: Jan 29th, 2007, 4:51pm
Thank you for choosing us
 
As for new pages, yes, until/unless MS fixes that bug, you should add this code.
Posted by: John McCallum Posted on: Feb 25th, 2008, 9:43am
Just wanted to add that the work around worked fine for me and reinforce that the code goes in the large box (don't even look at the load or save button
 
Thanks V.V.!
John
 
PS.  I needed to get info about my company on the web in a hurry (www.cityplaceservices.com) and this was the best way to do it!  Now that I have basic, accurate info on the web that functions, I can take my time and learn more to add richer content.
Posted by: xiqrabltu ydospznr Posted on: May 12th, 2008, 2:58pm
aywosxv iqvky cuawygev pbyrwq pekuja snjf rewuvnj


VisualVision main Web site
Easy software tools from Visual Vision:

Visual Vision **User's** Forum (the fast) » Powered by YaBB 1 Gold - SP1!
YaBB © 2000-2001, XNull. All Rights Reserved.
This forum © 2001-2010 VisualVision and VisualVision Users